PHP, which is a recursive abbreviation for PHP: Hypertext Preprocessor, is among the most popular imperative programming languages out there. Any website or web application built on PHP will run on a given web server as long as a PHP module is activated, which makes the language really universal and it is by no means surprising that there are several million web servers that support it and hundreds of millions of PHP-powered websites hosted on them. PHP is preferred over HTML because it enables you to build an interactive site with an abundance of different features. A PHP-based community site, for example, will serve different web content to each visitor even though the URL will not change. In contrast, HTML websites are static and the page content itself can be modified only manually. Like any other software program, PHP has different versions and the one that was used while developing a specific website must be present on the web server so that the site can run properly.

PHP 4, PHP 5 and PHP 7 Support in Cloud Hosting

Our cloud hosting servers support different PHP versions, which goes to say that your sites will work correctly even if your scripts are out of date. We accept the fact that an old website does not necessarily mean a vulnerable one as you may have done a lot of source code modifications. That’s the reason why we support PHP 4, PHP 5 and PHP 7 and you can choose which version will be active for your shared hosting account. You can change the version with only one click from your Hepsia hosting Control Panel and the new settings will be applied right away. If you want to run both newer and older scripts, there is even a possibility to use a different PHP version for each domain of yours simultaneously.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

In case you’ve got a site based on an older version of PHP and you have committed time and effort to developing it, plugging security gaps and publishing web content, you’ll need a web hosting service that can support it, as the vast majority of web hosting suppliers today offer support only for the most recently released version of PHP and remove the previous versions. We, however, have decided to let you select the version that your own sites require. Our Linux semi-dedicated hosting support PHP 4, PHP 5 and PHP 7, which means that you’ll be able to run both older and newer scripts without losing any manual tweaks or misspending time and energy trying to make your sites compatible with the web hosting environment. You can change the current version via the Hepsia hosting Control Panel and such an update will affect the whole semi-dedicated server account, but you will also be able to specify a different PHP version for each single site hosted in your account by using an .htaccess file.